<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" xmlns:og="http://ogp.me/ns#" xmlns:fb="http://ogp.me/ns/fb#"> <!--<![endif]-->
<head>
    <title>Horoscope: March 8, 2020 | TCU 360</title>
    <meta charset="UTF-8" /><script type="text/javascript">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</script>
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://www.tcu360.com/xmlrpc.php" />
    				<script>
								</script>
					<script type="text/javascript">
		var ajaxurl = 'https://www.tcu360.com/wp-admin/admin-ajax.php';
		</script>
		<link rel='dns-prefetch' href='//www.tcu360.com' />
<link rel='dns-prefetch' href='//translate.google.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="TCU 360 &raquo; Feed" href="https://www.tcu360.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="TCU 360 &raquo; Comments Feed" href="https://www.tcu360.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.tcu360.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='navis-slides-css'  href='https://www.tcu360.com/wp-content/plugins/argoproject-navis-slideshows-9505357/css/slides.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='h5ab-print-font-awesome-css'  href='https://www.tcu360.com/wp-content/plugins/print-post-and-page/css/font-awesome.min.css?ver=5.2' type='text/css' media='all' />
<link rel='stylesheet' id='h5ab-print-css-css'  href='https://www.tcu360.com/wp-content/plugins/print-post-and-page/css/h5ab-print.min.css?ver=5.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://www.tcu360.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='ditty-news-ticker-font-css'  href='https://www.tcu360.com/wp-content/plugins/ditty-news-ticker/legacy/static/libs/fontastic/styles.css?ver=2.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='ditty-news-ticker-css'  href='https://www.tcu360.com/wp-content/plugins/ditty-news-ticker/legacy/static/css/style.css?ver=1583697346' type='text/css' media='all' />
<link rel='stylesheet' id='fvp-frontend-css'  href='https://www.tcu360.com/wp-content/plugins/featured-video-plus/styles/frontend.css?ver=2.3.3' type='text/css' media='all' />
<link rel='stylesheet' id='google-language-translator-css'  href='https://www.tcu360.com/wp-content/plugins/google-language-translator/css/style.css?ver=5.0.48' type='text/css' media='' />
<link rel='stylesheet' id='glt-toolbar-styles-css'  href='https://www.tcu360.com/wp-content/plugins/google-language-translator/css/toolbar.css?ver=5.0.48' type='text/css' media='' />
<link rel='stylesheet' id='sb_instagram_styles-css'  href='https://www.tcu360.com/wp-content/plugins/instagram-feed/css/sb-instagram.min.css?ver=1.12' type='text/css' media='all' />
<link rel='stylesheet' id='sb-font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='simple-job-board-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Roboto%3A100%2C100i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C700%2C700i%2C900%2C900i&#038;ver=2.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='simple-job-board-font-awesome-css'  href='https://www.tcu360.com/wp-content/plugins/simple-job-board/public/css/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='simple-job-board-jquery-ui-css'  href='https://www.tcu360.com/wp-content/plugins/simple-job-board/public/css/jquery-ui.css?ver=1.12.1' type='text/css' media='all' />
<link rel='stylesheet' id='simple-job-board-frontend-css'  href='https://www.tcu360.com/wp-content/plugins/simple-job-board/public/css/simple-job-board-public.css?ver=3.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='simple-staff-list-css'  href='https://www.tcu360.com/wp-content/plugins/simple-staff-list/public/css/simple-staff-list-public.css?ver=2.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='wpemfb-lightbox-css'  href='https://www.tcu360.com/wp-content/plugins/wp-embed-facebook/lib/lightbox2/css/lightbox.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='wp-parsely-style-css'  href='https://www.tcu360.com/wp-content/plugins/wp-parsely/wp-parsely.css?ver=1583697347' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css'  href='https://www.tcu360.com/wp-content/plugins/td-multi-purpose/style.css?ver=5.2' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Open+Sans+Condensed%3A400%2C300%2C600%2C700%7COpen+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%2C300%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900%2C600&#038;ver=8.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://www.tcu360.com/wp-content/themes/Newspaper/style.css?ver=8.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-child-css'  href='https://www.tcu360.com/wp-content/themes/Newspaper-child/style.css?ver=8.7.4c' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/7.0.1/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/5.2/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.2/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript' src='https://www.tcu360.com/wp-content/plugins/featured-video-plus/js/jquery.fitvids.min.js?ver=master-2015-08'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var fvpdata = {"ajaxurl":"https:\/\/www.tcu360.com\/wp-admin\/admin-ajax.php","nonce":"122cc30275","fitvids":"1","dynamic":"","overlay":"","opacity":"0.75","color":"b","width":"640"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.tcu360.com/wp-content/plugins/featured-video-plus/js/frontend.min.js?ver=2.3.3'></script>
<script type='text/javascript' src='https://www.tcu360.com/wp-content/plugins/wp-embed-facebook/lib/lightbox2/js/lightbox.min.js?ver=1.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WEF = {"local":"en_US","version":"v2.11","fb_id":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.tcu360.com/wp-content/plugins/wp-embed-facebook/lib/js/fb.min.js?ver=1.1'></script>
<link rel='https://api.w.org/' href='https://www.tcu360.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.tcu360.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.tcu360.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Horoscope: March 7, 2020' href='https://www.tcu360.com/2020/03/horoscope-march-7-2020/' />
<meta name="generator" content="WordPress 5.2" />
<link rel="canonical" href="https://www.tcu360.com/2020/03/horoscope-march-8-2020/" />
<link rel='shortlink' href='https://wp.me/paKdEn-5dza' />
<link rel="alternate" type="application/json+oembed" href="https://www.tcu360.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.tcu360.com%2F2020%2F03%2Fhoroscope-march-8-2020%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.tcu360.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.tcu360.com%2F2020%2F03%2Fhoroscope-march-8-2020%2F&#038;format=xml" />
    	<style type="text/css">.navis-slideshow  {width: 94%;} .navis-slideshow .slides_container div {width: 100%;}</style>
    			<meta property="fb:pages" content="123940397682961" />
			<style type="text/css">#glt-translate-trigger {
font-weight: 200;
text-shadow: none;
font-family: Open Sans Condensed;
font-size: 16px;
padding-bottom: 5px;
}#google_language_translator { width:auto !important; }.goog-tooltip {display: none !important;}.goog-tooltip:hover {display: none !important;}.goog-text-highlight {background-color: transparent !important; border: none !important; box-shadow: none !important;}#google_language_translator select.goog-te-combo { color:#32373c; }#flags { display:none; }#google_language_translator {color: transparent;}body { top:0px !important; }#glt-translate-trigger { left:20px; right:auto; }#glt-translate-trigger > span { color:#ffffff; }#glt-translate-trigger { background:#9e75cb; }.goog-te-gadget .goog-te-combo { width:100%; }</style>
<!-- BEGIN wp-parsely Plugin Version 1.13.0 -->
<meta name="wp-parsely_version" id="wp-parsely_version" content="1.13.0"/>
	<script type="application/ld+json">
	{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"http:\/\/www.tcu360.com\/2020\/03\/horoscope-march-8-2020\/"},"headline":"Horoscope: March 8, 2020","url":"http:\/\/www.tcu360.com\/2020\/03\/horoscope-march-8-2020\/","dateCreated":"2020-03-08T15:00:15Z","datePublished":"2020-03-08T15:00:15Z","dateModified":"2020-03-08T15:00:15Z","articleSection":"Horoscopes","author":[{"@type":"Person","name":"Tamia Banks"}],"creator":["Tamia Banks"],"keywords":[],"publisher":{"@type":"Organization","name":"TCU 360","logo":{"@type":"ImageObject","url":""}}}
	</script>

	<!-- END wp-parsely Plugin Version 1.13.0 -->

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//c0.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style>			<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/www.tcu360.com\/wp-admin\/","wpRestNonce":"86e58eb804","wpRestUrl":"https:\/\/www.tcu360.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%postname%\/"};
			</script>
			<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
          <meta name="onesignal" content="wordpress-plugin"/>
          <link rel="manifest"
            href="https://www.tcu360.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/manifest.json.php?gcm_sender_id="/>
          <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>    <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://www.tcu360.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '6f5034d0-16f0-4dd6-b8d3-2b70296fee74';
oneSignal_options['autoRegister'] = false;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://www.tcu360.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.1f4dfa09-73a7-4180-b8dc-d98896f4fb85";
oneSignal_options['promptOptions'] = { };
oneSignal_options['promptOptions']['actionMessage'] = 'We would like to show you notifications for the latest news and updates.';
oneSignal_options['promptOptions']['exampleNotificationTitleDesktop'] = 'TCU 360 News';
oneSignal_options['promptOptions']['exampleNotificationTitleMobile'] = 'TCU 360 News';
oneSignal_options['promptOptions']['siteName'] = 'https://www.tcu360.com';
oneSignal_options['promptOptions']['autoAcceptTitle'] = 'Click Allow';
              oneSignal_options['autoRegister'] = false;
              OneSignal.showHttpPrompt();
              OneSignal.init(window._oneSignalInitOptions);
                    });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>


<!-- JS generated by theme -->

<script>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</script>


<!-- Header style compiled by theme -->

<style>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</style>


<!-- BEGIN GADWP v5.3.3 Universal Analytics - https://exactmetrics.com/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-2413775-1', 'auto');
  ga('send', 'pageview');
</script>
<!-- END GADWP Universal Analytics -->

<!-- Button style compiled by theme -->

<style>
    .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .current-category-ancestor > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .current-menu-ancestor > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .current-menu-item > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .sfHover > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > li > a:hover,
                .tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                .tdm-social-item i {
                  color: #4f2a78;
                }
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > .current-menu-item > a,
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > .current-menu-ancestor > a,
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > .current-category-ancestor > a,
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > li > a:hover,
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > .sfHover > a,
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                  background-color: #4f2a78;
                }
                .tdm-menu-active-style4 .tdm-header .sf-menu > .current-menu-item > a,
                .tdm-menu-active-style4 .tdm-header .sf-menu > .current-menu-ancestor > a,
                .tdm-menu-active-style4 .tdm-header .sf-menu > .current-category-ancestor > a,
                .tdm-menu-active-style4 .tdm-header .sf-menu > li > a:hover,
                .tdm-menu-active-style4 .tdm-header .sf-menu > .sfHover > a,
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #4f2a78;
                }
                .tdm-btn-style1 {
					background-color: #4f2a78;
				}
				.tdm-btn-style2:before {
				    border-color: #4f2a78;
				}
				.tdm-btn-style2 {
				    color: #4f2a78;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #4f2a78;
                    -moz-box-shadow: 0 2px 16px #4f2a78;
                    box-shadow: 0 2px 16px #4f2a78;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #4f2a78;
                    -moz-box-shadow: 0 4px 26px #4f2a78;
                    box-shadow: 0 4px 26px #4f2a78;
				}
				
				
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .current-menu-item > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .current-menu-ancestor > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .current-category-ancestor > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > li > a:hover,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .sfHover > a {
                  color: #4f2a78;
                }
                .tdm-menu-active-style4 .tdm-header .sf-menu > .current-menu-item > a,
                .tdm-menu-active-style4 .tdm-header .sf-menu > .current-menu-ancestor > a,
                .tdm-menu-active-style4 .tdm-header .sf-menu > .current-category-ancestor > a,
                .tdm-menu-active-style4 .tdm-header .sf-menu > li > a:hover,
                .tdm-menu-active-style4 .tdm-header .sf-menu > .sfHover > a {
                  border-color: #4f2a78;
                }
                .tdm-menu-active-style5 .tdm-header .td-header-menu-wrap .sf-menu > .current-menu-item > a,
                .tdm-menu-active-style5 .tdm-header .td-header-menu-wrap .sf-menu > .current-menu-ancestor > a,
                .tdm-menu-active-style5 .tdm-header .td-header-menu-wrap .sf-menu > .current-category-ancestor > a,
                .tdm-menu-active-style5 .tdm-header .td-header-menu-wrap .sf-menu > li > a:hover,
                .tdm-menu-active-style5 .tdm-header .td-header-menu-wrap .sf-menu > .sfHover > a {
                  background-color: #4f2a78;
                }
</style>


<!-- START - Open Graph for Facebook, Google+ and Twitter Card Tags 2.2.4.2 -->
 <!-- Facebook Open Graph -->
  <meta property="og:locale" content="en_US"/>
  <meta property="og:site_name" content="TCU 360"/>
  <meta property="og:title" content="Horoscope: March 8, 2020"/>
  <meta property="og:url" content="https://www.tcu360.com/2020/03/horoscope-march-8-2020/"/>
  <meta property="og:type" content="article"/>
  <meta property="og:description" content="A baby born today has a Sun in Pisces and a Moon in Leo until 6:47 p.m., when the Moon enters Virgo.
HAPPY BIRTHDAY for Sunday, March 8, 2020: This year could be more significant than you realize. You will be able to understand both sidesof an issue. Therefore, fighting to win becomes les important."/>
  <meta property="og:image" content="https://s3-us-east-2.amazonaws.com/tcu360/wp-content/uploads/2018/09/07121943/StudentMediaNewFrogLogo.png"/>
  <meta property="article:published_time" content="2020-03-08T10:00:15-05:00"/>
  <meta property="article:modified_time" content="2020-03-05T12:05:38-05:00" />
  <meta property="og:updated_time" content="2020-03-05T12:05:38-05:00" />
  <meta property="article:section" content="Horoscopes"/>
  <meta property="article:section" content="News"/>
  <meta property="article:publisher" content="https://www.facebook.com/TCU360/"/>
  <meta property="fb:app_id" content="779840945548245"/>
  <meta property="fb:admins" content="2402980"/>
 <!-- Google+ / Schema.org -->
  <meta itemprop="name" content="Horoscope: March 8, 2020"/>
  <meta itemprop="headline" content="Horoscope: March 8, 2020"/>
  <meta itemprop="description" content="A baby born today has a Sun in Pisces and a Moon in Leo until 6:47 p.m., when the Moon enters Virgo.
HAPPY BIRTHDAY for Sunday, March 8, 2020: This year could be more significant than you realize. You will be able to understand both sidesof an issue. Therefore, fighting to win becomes les important."/>
  <meta itemprop="image" content="https://s3-us-east-2.amazonaws.com/tcu360/wp-content/uploads/2018/09/07121943/StudentMediaNewFrogLogo.png"/>
  <meta itemprop="datePublished" content="2020-03-08"/>
  <meta itemprop="dateModified" content="2020-03-05T12:05:38-05:00" />
  <meta itemprop="author" content="Tamia Banks"/>
 <!-- Twitter Cards -->
  <meta name="twitter:title" content="Horoscope: March 8, 2020"/>
  <meta name="twitter:url" content="https://www.tcu360.com/2020/03/horoscope-march-8-2020/"/>
  <meta name="twitter:description" content="A baby born today has a Sun in Pisces and a Moon in Leo until 6:47 p.m., when the Moon enters Virgo.
HAPPY BIRTHDAY for Sunday, March 8, 2020: This year could be more significant than you realize. You will be able to understand both sidesof an issue. Therefore, fighting to win becomes les important."/>
  <meta name="twitter:card" content="summary_large_image"/>
 <!-- SEO -->
 <!-- Misc. tags -->
 <!-- is_singular -->
<!-- END - Open Graph for Facebook, Google+ and Twitter Card Tags 2.2.4.2 -->
	
	<style id="tdw-css-placeholder"></style>
    <script src="https://cdn.broadstreetads.com/init-2.min.js"></script>
    <script>broadstreet.watch({ networkId: 1876 })</script>

    <script id="mcjs">!function(c,h,i,m,p){m=c.createElement(h),p=c.getElementsByTagName(h)[0],m.async=1,m.src=i,p.parentNode.insertBefore(m,p)}(document,"script","https://chimpstatic.com/mcjs-connected/js/users/8e2a16f0a7bfa97de96d28091/7c4172a9e75f2221f5a8e5c87.js");</script>

    <link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.7.1/css/all.css" integrity="sha384-fnmOCqbTlWIlj8LyTjo7mOUStjsKC4pOpQbqyi7RrhN7udi9RwhKkMHpvLbHG9Sr" crossorigin="anonymous">

    <style> /* style for the news ticker - to be removed after new style sheet appears on site */

        .mtphr-dnt-tick-container { padding: 10px 0px; color: white; background-color: #EB5B55; }
        .mtphr-dnt-tick-container a { color: white; font-weight: bold; }

        .image-current-issue {
            padding: 10px;
            background-color: #F200CC;
            margin-bottom: 20px;
        }

        .image-current-issue .widget {
            margin-bottom: 0px;
        }

    </style>

</head>

<body class="post-template-default single single-post postid-1243792 single-format-standard horoscope-march-8-2020 global-block-template-1 newspaper-7-child-theme td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/TCU360/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/tcu360" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://vimeo.com/tcustudentmedia" title="Vimeo">
                <i class="td-icon-font td-icon-vimeo"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-main-navigation-container"><ul id="menu-main-navigation" class="td-mobile-main-menu"><li id="menu-item-1169100" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-first menu-item-1169100"><a href="https://www.tcu360.com/category/news/">News</a></li>
<li id="menu-item-1041827" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1041827"><a href="https://www.tcu360.com/category/sports/">Sports</a></li>
<li id="menu-item-1224558" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1224558"><a href="https://www.tcu360.com/category/a-and-e/">Entertainment</a></li>
<li id="menu-item-1210545" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1210545"><a href="https://www.tcu360.com/welcome-to-tcu/">TCU Map</a></li>
<li id="menu-item-1041822" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1041822"><a href="https://www.tcu360.com/about-tcu-360/">About</a></li>
<li id="menu-item-1186740" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1186740"><a href="https://www.tcu360.com/adlab/">AdLab</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="https://www.tcu360.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap" class="td-theme-wrap">
    
        <!-- The line below is for the news ticker, added by CC -->

        
        <!--
Header style 1
-->


<div class="td-header-wrap td-header-style-1 td-header-background-image">
            <div class="td-header-bg td-container-wrap "></div>
    
    <div class="td-header-top-menu-full td-container-wrap ">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-2">
        <div class="td-header-sp-top-widget">
    
    </div>        
<div class="td-header-sp-top-menu">


	<!-- td weather source: cache -->		<div class="td-weather-top-widget" id="td_top_weather_uid">
			<i class="td-icons broken-clouds-d"></i>
			<div class="td-weather-now" data-block-uid="td_top_weather_uid">
				<span class="td-big-degrees">63.8</span>
				<span class="td-weather-unit">F</span>
			</div>
			<div class="td-weather-header">
				<div class="td-weather-city">Fort Worth</div>
			</div>
		</div>
		<div class="menu-top-container"><ul id="menu-global-navigation" class="top-header-menu"><li id="menu-item-1170810" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-normal-menu menu-item-1170810"><a href="https://www.tcu360.com/category/the-skiff-digital-issues/">The Skiff</a></li>
<li id="menu-item-1168976" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-1168976"><a href="https://www.tcu360.com/category/the-109/">The 109</a></li>
<li id="menu-item-1224557" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-1224557"><a href="https://www.tcu360.com/category/pfrog/pfrog-news/">PolitiFrog</a></li>
<li id="menu-item-1168977" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-1168977"><a href="https://www.tcu360.com/category/image-magazine/">Image Magazine</a></li>
</ul></div></div>
    </div>

<!-- LOGIN MODAL -->
        </div>
    </div>

    <div class="td-banner-wrap-full td-logo-wrap-full td-container-wrap ">
        <div class="td-container td-header-row td-header-header">
            <div class="td-header-sp-logo">
                            <a class="td-main-logo" href="https://www.tcu360.com/">
                <img src="https://www.tcu360.com/wp-content/uploads/2018/08/TCU360NewLogo-wTextnSpacey-1024x404.png" alt="TCU 360" title="TCU 360: All TCU. All the time."/>
                <span class="td-visual-hidden">TCU 360</span>
            </a>
                    </div>
                            <div class="td-header-sp-recs">
                    <div class="td-header-rec-wrap">
    <div class="td-a-rec td-a-rec-id-header  td_uid_1_5e65572e620f0_rand td_block_template_1"><script src="https://cdn.broadstreetads.com/init-2.min.js"></script>
<script>broadstreet.watch({ networkId: 1876 })</script>

<div class="desktop-ad-tcu">
<broadstreet-zone zone-id="32018"></broadstreet-zone>
</div>

<div class="mobile-ad-tcu">
<broadstreet-zone zone-id="32634"></broadstreet-zone>
</div></div>
</div>                </div>
                    </div>
    </div>

    <div class="td-header-menu-wrap-full td-container-wrap ">
        
        <div class="td-header-menu-wrap td-header-gradient ">
            <div class="td-container td-header-row td-header-main-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-header">
        		<a class="td-mobile-logo td-sticky-mobile" href="https://www.tcu360.com/">
			<img src="https://www.tcu360.com/wp-content/uploads/2018/08/TCU360NewLogo-wTextnSpacey-1024x404.png" alt="TCU 360" title="TCU 360: All TCU. All the time."/>
		</a>
			<a class="td-header-logo td-sticky-mobile" href="https://www.tcu360.com/">
			<img src="https://www.tcu360.com/wp-content/uploads/2018/08/TCU360NewLogo-wTextnSpacey-1024x404.png" alt="TCU 360" title="TCU 360: All TCU. All the time."/>
		</a>
	    </div>
    <div class="menu-main-navigation-container"><ul id="menu-main-navigation-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-first td-menu-item td-normal-menu menu-item-1169100"><a href="https://www.tcu360.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-1041827"><a href="https://www.tcu360.com/category/sports/">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-1224558"><a href="https://www.tcu360.com/category/a-and-e/">Entertainment</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-1210545"><a href="https://www.tcu360.com/welcome-to-tcu/">TCU Map</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-1041822"><a href="https://www.tcu360.com/about-tcu-360/">About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-1186740"><a href="https://www.tcu360.com/adlab/">AdLab</a></li>
</ul></div></div>

<div class="td-header-menu-social">
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/TCU360/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/tcu360" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://vimeo.com/tcustudentmedia" title="Vimeo">
                <i class="td-icon-font td-icon-vimeo"></i>
            </a>
        </span></div>
    <div class="header-search-wrap">
        <div class="td-search-btns-wrap">
            <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
        </div>

        <div class="td-drop-down-search" aria-labelledby="td-header-search-button">
            <form method="get" class="td-search-form" action="https://www.tcu360.com/">
                <div role="search" class="td-head-form-search-wrap">
                    <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
                </div>
            </form>
            <div id="td-aj-search"></div>
        </div>
    </div>
            </div>
        </div>
    </div>

</div><div class="td-main-content-wrap td-container-wrap">

    <div class="td-container td-post-template-default ">
        <div class="td-crumb-container"></div>

        <div class="td-pb-row">
                                    <div class="td-pb-span12 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-1243792" class="post-1243792 post type-post status-publish format-standard hentry category-horoscopes category-news" itemscope itemtype="https://schema.org/Article">
        <div class="td-post-header">

            <ul class="td-category"><li class="entry-category"><a  href="https://www.tcu360.com/category/horoscopes/">Horoscopes</a></li><li class="entry-category"><a  href="https://www.tcu360.com/category/news/">News</a></li></ul>
            <header class="td-post-title">
                <h1 class="entry-title">Horoscope: March 8, 2020</h1>

                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://www.tcu360.com/author/tbanks/">Tamia Banks</a><div class="td-author-line"> - </div> </div>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-08T10:00:15+00:00" >March 8, 2020</time></span>                    <div class="td-post-comments"><a href="https://www.tcu360.com/2020/03/horoscope-march-8-2020/#respond"><i class="td-icon-comments"></i>0</a></div>                    <div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-1243792">36</span></div>                </div>

            </header>

        </div>

        <div class="td-post-sharing-top"><div id="td_uid_2_5e65572e64ffc" class="td-post-sharing td-ps-bg td-ps-notext td-ps-bar td-post-sharing-style5 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.tcu360.com%2F2020%2F03%2Fhoroscope-march-8-2020%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Horoscope%3A+March+8%2C+2020&url=https%3A%2F%2Fwww.tcu360.com%2F2020%2F03%2Fhoroscope-march-8-2020%2F&via=tcu360">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_uid_2_5e65572e64ffc">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>

        <div class="td-post-content">

        
        <div id="fb-root"></div>
<div class="h5ab-print-button-container"><div class="h5ab-print-button h5ab-print-button-right" style="cursor: pointer; color: #482a6a"><i class="fa fa-print fa-lg"></i>
							<span>Print Article</span></div></div><p>A baby born today has a Sun in Pisces and a Moon in Leo until 6:47 p.m., when the Moon enters Virgo.</p>
<p class="happy-bday"><strong>HAPPY BIRTHDAY for Sunday, March 8, 2020:</strong> This year could be more significant than you realize. You will be able to understand both sidesof an issue. Therefore, fighting to win becomes les important. If you are single, you will draw people who will tend to cause excitement in your life. Enjoy the roller coaster ride, but do not make commitments yet. If attached, the two of you often disagree, but you also respect your differences. You find a midpoint or resolution more easily. VIRGO tends to be emotional when dealing with others.</p>


<hr class="wp-block-separator is-style-wide"/>



<p>The Stars Show the Kind of Day You&#8217;ll Have: 5-Dynamic; 4-Positive; 3-Average; 2-So-so; 1-Difficult</p>
<hr style="margin-bottom: 20px;">
	   
<p id="aries"><h2>ARIES (March 21-April 19)</h2></p> 
<span class="three-stars"><p>You might want to touch base with a dear friend today. You have a lot of projects to get done. Great ideas pop up out of the blue when sharing with this person. Tonight: Get a head start on tomorrow.</p>
<p>This Week: Much goes on behind the scenes. Hold back and observe.</p>
<hr style="margin-bottom: 20px;">

<p id="taurus"><h2>TAURUS (April 20-May 20)</h2></p>
<span class="four-stars"><p>You come out of your cocoon ready to go out and enjoy your loved ones, or perhaps take the kids to the zoo. Wherever you are, a good time is had by all. A conversation points to a fun idea. Tonight: Put your best foot forward.</p>
<p>This Week: A situation could push your creativity forward.</p>
<hr style="margin-bottom: 20px;">

<p id="gemini"><h2>GEMINI (May 21-June 20)</h2></p>
<span class="three-stars"><p>You have a tendency to go beyond the call of duty. You cannot get a situation under control with your normal ease. The unexpected runs wild, and an element of confusion could mount. Tonight: Head home early.</p>
<p>This Week: Basics count. You might need to review your priorities.</p>
<hr style="margin-bottom: 20px;">

<p id="cancer"><h2>CANCER (June 21-July 22)</h2></p> 
<span class="four-stars"><p>You speak your mind and others listen. Someone might become confused and unsure of which way to go. You might need to answer a lot of questions and clarify. Tonight: Speak your mind.</p>
<p>This Week: Do not allow a small difference to develop into anything more.</p>
<hr style="margin-bottom: 20px;">

<p id="leo"><h2>LEO (July 23-Aug. 22)</h2></p>
<span class="four-stars"><p>You are high energy, and your creativity emerges. Expenses could go out of whack if you are not careful. Someone you look up to could be unusually unpredictable. Follow through on a loved one&#8217;s suggestion. Tonight: Go for a good night&#8217;s sleep.</p>
<p>This Week: You will make a difference if you take charge of your finances.</p>
<hr style="margin-bottom: 20px;">

<p id="virgo"><h2>VIRGO (Aug. 23-Sept. 22)</h2></p>
<span class="four-stars"><p>You wake up energetic and ready to break a pattern. You might opt to join a friend who often inspires you to be more adventuresome. Unexpected news comes forward. You could be stunned but might choose to not react. Tonight: As you like it.</p>
<p>This Week: You have choices to make. Keep your interests in mind.</p>
<hr style="margin-bottom: 20px;">

<p id="libra"><h2>LIBRA (Sept. 23-Oct. 22)</h2></p> 
<span class="two-stars"><p>Every so often you need to take a personal day, sleep in and do what you want. Use today for this type of R and R. You might be happiest playing it low-key and not visiting with others. Tonight: Not to be found.</p>
<p>This Week: You make a difference to a loved one.</p>
<hr style="margin-bottom: 20px;">

<p id="scorpio"><h2>SCORPIO (Oct. 23-Nov. 21)</h2></p>
<span class="five-stars"><p> An invitation might come forward that tosses you together with friends and people you like. Whatever is happening might not be as important as the get-together. Share an imaginative idea with a loved one. Tonight: Where the crowds are.</p>
<p>This Week: Zero in on your priorities.</p>
<hr style="margin-bottom: 20px;">

<p id="sagittarius"><h2>SAGITTARIUS (Nov. 22-Dec. 21)</h2></p>
<span class="three-stars"><p>Pressure builds, and you must check in with an older friend, relative or boss. Responsibilities keep being tossed at you. Allow yourself to say no. You could be a lot happier. Tonight: Indulge a family member.</p>
<p>This Week: Touch base with a child or a loved one.</p>
<hr style="margin-bottom: 20px;">

<p id="capricorn"><h2>CAPRICORN (Dec. 22-Jan. 19)</h2></p>
<span class="five-stars"><p>Read between the lines, knowing full well you might not be able to help another person. Rather, accept where he or she is coming from. A call could trigger an imaginative idea or fantasy. Tonight: At a favorite spot.</p>
<p>This Week: Reach out for someone at a distance.</p>
<hr style="margin-bottom: 20px;">

<p id="aquarius"><h2>AQUARIUS (Jan. 20-Feb. 18)</h2></p>
<span class="five-stars"><p>You might need to make an important change that could cause some tension between you and a partner. What happens could be a problem, but it will only be short-term if you do not hang on to the issue. Tonight: Be with a favorite person.</p>
<p>This Week: One-on-one relating draws happy results.</p>
<hr style="margin-bottom: 20px;">

<p id=“pisces”><h2>PISCES (Feb. 19-March 20)</h2></p>
<span class="four-stars"><p>Defer to a loved one who cares a lot about what happens between the two of you. Sometimes you are too emotional to make a good choice. Let the other party reveal his or her true colors. Tonight: The only answer is yes.</p>
<p>This Week: Relationship issues come to the forefront.</p>
<hr style="margin-bottom: 20px;">
	   
<p class="happy-bday">Born today: News anchor Lester Holt (1959), tattoo artist Kat Von D (1982), actor James Van Der Beek (1977)</p>
<hr style="margin-bottom: 20px;">
        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                            </div>

            <div class="td-post-sharing-bottom"><div id="td_uid_4_5e65572e667de" class="td-post-sharing td-ps-bg td-ps-notext td-ps-bar td-post-sharing-style5 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.tcu360.com%2F2020%2F03%2Fhoroscope-march-8-2020%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Horoscope%3A+March+8%2C+2020&url=https%3A%2F%2Fwww.tcu360.com%2F2020%2F03%2Fhoroscope-march-8-2020%2F&via=tcu360">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_uid_4_5e65572e667de">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>            <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://www.tcu360.com/2020/03/horoscope-march-7-2020/">Horoscope: March 7, 2020</a></div></div><div class="td-next-prev-separator"></div></div>            <div class="author-box-wrap"><a href="https://www.tcu360.com/author/tbanks/"><img alt='' src='https://secure.gravatar.com/avatar/6d6080c3faf9e7d5032ef6bf6c3300d4?s=96&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/6d6080c3faf9e7d5032ef6bf6c3300d4?s=192&#038;d=mm&#038;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://www.tcu360.com/author/tbanks/">Tamia Banks</a></span></div><div class="td-author-description"></div><div class="td-author-social"></div><div class="clearfix"></div></div></div>	        <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Tamia Banks"></span><meta itemprop="datePublished" content="2020-03-08T10:00:15+00:00"><meta itemprop="dateModified" content="2020-03-05T12:05:38-05:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.tcu360.com/2020/03/horoscope-march-8-2020/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.tcu360.com/wp-content/uploads/2018/08/TCU360NewLogo-wTextnSpacey-1024x404.png"></span><meta itemprop="name" content="TCU 360"></span><meta itemprop="headline " content="Horoscope: March 8, 2020"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.tcu360.com/wp-content/themes/Newspaper/images/no-thumb/td_meta_replacement.png"><meta itemprop="width" content="1068"><meta itemprop="height" content="580"></span>        </footer>

    </article> <!-- /.post -->

    
	<div class="comments" id="comments">
            </div> <!-- /.content -->
                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->

<!-- Instagram -->




	<!-- Footer -->
	<div class="td-footer-wrapper td-container-wrap td-footer-template-3 ">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
                		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span4">
                <div class="td-footer-info"><div class="footer-logo-wrap"><a href="https://www.tcu360.com/"><img src="https://www.tcu360.com/wp-content/uploads/2018/08/TCU360NewLogo-wTextnSpacey-1024x404.png" alt="TCU 360" title="TCU 360: All TCU. All the time."/></a></div><div class="footer-text-wrap"></div><div class="footer-social-wrap td-social-style-2">
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/TCU360/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/tcu360" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://vimeo.com/tcustudentmedia" title="Vimeo">
                <i class="td-icon-font td-icon-vimeo"></i>
            </a>
        </span></div></div>            </div>

            <div class="td-pb-span4">
                <div class="td_block_wrap td_block_instagram td_block_widget td_uid_6_5e65572e68895_rand td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_6_5e65572e68895" ><div class="td-block-title-wrap"><h4 class="block-title td-block-title"><span class="td-pulldown-size">TCU360 on Instagram</span></h4></div><div id=td_uid_6_5e65572e68895 class="td-instagram-wrap td_block_inner td-column-1"><!-- td instagram source: instagram_cache -->        <!-- header section -->
        
        <!-- user shared images -->
                    <div class="td-instagram-main td-images-on-row-2 td-image-gap-2">
                                        <div class="td-instagram-element">
                            <!-- image -->
                            <a href="https://www.instagram.com/p/B9XC9ESn0gO" target="_blank">
                                <img class="td-instagram-image" src="https://scontent-atl3-1.cdninstagram.com/v/t51.2885-15/sh0.08/e35/c0.280.720.720a/s640x640/89202332_651677078924124_3262433156880064022_n.jpg?_nc_ht=scontent-atl3-1.cdninstagram.com&_nc_cat=100&_nc_ohc=0qD0gQXsLSQAX_Is1S4&oh=29e24413ac43c7c8bb63e0438b7e8110&oe=5E67F7D3"/>
                            </a>
                            <!-- video icon -->
                                                            <span class="td-video-play-ico">
                                    <img width="40" class="td-retina" src="https://www.tcu360.com/wp-content/themes/Newspaper/images/icons/ico-video-large.png" alt="video"/>
                                </span>
                                                        </div>
                                            <!-- number of images to display -->
                                            <div class="td-instagram-element">
                            <!-- image -->
                            <a href="https://www.instagram.com/p/B9U9UCBn7kq" target="_blank">
                                <img class="td-instagram-image" src="https://scontent-atl3-1.cdninstagram.com/v/t51.2885-15/sh0.08/e35/c240.0.960.960a/s640x640/88183161_532489987404506_4453773865486061666_n.jpg?_nc_ht=scontent-atl3-1.cdninstagram.com&_nc_cat=102&_nc_ohc=7uNvXyASgYcAX8p9Pci&oh=87bbd5fcf366a2e721f76726e0904426&oe=5E8E2C3F"/>
                            </a>
                            <!-- video icon -->
                                                    </div>
                                            <!-- number of images to display -->
                                            <div class="td-instagram-element">
                            <!-- image -->
                            <a href="https://www.instagram.com/p/B9S2XsSH7d3" target="_blank">
                                <img class="td-instagram-image" src="https://scontent-atl3-1.cdninstagram.com/v/t51.2885-15/sh0.08/e35/c111.0.1218.1218a/s640x640/83614759_133566928178221_4999948311822733814_n.jpg?_nc_ht=scontent-atl3-1.cdninstagram.com&_nc_cat=101&_nc_ohc=t8kVmOslHhEAX-Y1jsl&oh=cd4f541b89e66fe31923e1076691e537&oe=5E90260F"/>
                            </a>
                            <!-- video icon -->
                                                    </div>
                                            <!-- number of images to display -->
                                            <div class="td-instagram-element">
                            <!-- image -->
                            <a href="https://www.instagram.com/p/B9SsiESnOkk" target="_blank">
                                <img class="td-instagram-image" src="https://scontent-atl3-1.cdninstagram.com/v/t51.2885-15/e35/c157.0.405.405a/88991325_201946957556493_6537871241721465307_n.jpg?_nc_ht=scontent-atl3-1.cdninstagram.com&_nc_cat=109&_nc_ohc=E25Mv_t2KU4AX9xmjxO&oh=4a06ceb7296f89d14672c7df1ae3706b&oe=5E681778"/>
                            </a>
                            <!-- video icon -->
                                                            <span class="td-video-play-ico">
                                    <img width="40" class="td-retina" src="https://www.tcu360.com/wp-content/themes/Newspaper/images/icons/ico-video-large.png" alt="video"/>
                                </span>
                                                        </div>
                                            <!-- number of images to display -->
                                    <div class="clearfix"></div>
            </div>
            </div></div> <!-- ./block -->            </div>

            <div class="td-pb-span4">
                <aside class="td_block_template_1 widget widget_text"><h4 class="block-title"><span>About TCU 360</span></h4>			<div class="textwidget">TCU 360 is an official, student-produced product of the Department of Journalism in the Bob Schieffer College of Communication at Texas Christian University.

</div>
		</aside>            </div>
        </div>
    </div>
</div>
	<!-- Sub Footer -->
	    <div class="td-sub-footer-container td-container-wrap ">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span td-sub-footer-menu">
                    <div class="menu-main-navigation-container"><ul id="menu-main-navigation-2" class="td-subfooter-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-first td-menu-item td-normal-menu menu-item-1169100"><a href="https://www.tcu360.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-1041827"><a href="https://www.tcu360.com/category/sports/">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-1224558"><a href="https://www.tcu360.com/category/a-and-e/">Entertainment</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-1210545"><a href="https://www.tcu360.com/welcome-to-tcu/">TCU Map</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-1041822"><a href="https://www.tcu360.com/about-tcu-360/">About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-1186740"><a href="https://www.tcu360.com/adlab/">AdLab</a></li>
</ul></div>                </div>

                <div class="td-pb-span td-sub-footer-copy">
                    &copy; 2018 TCU Student Media                </div>
            </div>
        </div>
    </div>


</div><!--close td-outer-wrap-->

<div id="glt-translate-trigger"><span class="translate">Translate Page</span></div><div id="glt-toolbar"></div><div id="flags" style="display:none" class="size18"><ul id="sortable" class="ui-sortable"><li id="English"><a title="English" class="nturl notranslate en flag united-states"></a><li id="Spanish"><a title="Spanish" class="nturl notranslate es flag mexico"></a><li id="Vietnamese"><a title="Vietnamese" class="nturl notranslate vi flag Vietnamese"></a></ul></div><div id='glt-footer'><div id="google_language_translator" class="default-language-en"></div></div><script>function GoogleLanguageTranslatorInit() { new google.translate.TranslateElement({pageLanguage: 'en', includedLanguages:'en,es,vi', autoDisplay: false}, 'google_language_translator');}</script><!-- Instagram Feed JS -->
<script type="text/javascript">
var sbiajaxurl = "https://www.tcu360.com/wp-admin/admin-ajax.php";
</script>


<!-- START Parse.ly Include: Standard -->

<div id="parsely-root" style="display: none">
	<div id="parsely-cfg" data-parsely-site="tcu360.com"></div>
</div>
<script data-cfasync="false">
	(function (s, p, d) {
		var h = d.location.protocol, i = p + "-" + s,
			e = d.getElementById(i), r = d.getElementById(p + "-root"),
			u = h === "https:" ? "d1z2jf7jlzjs58.cloudfront.net"
				: "static." + p + ".com";
		if (e) return;
		e = d.createElement(s);
		e.id = i;
		e.async = true;
		e.setAttribute('data-cfasync', 'false');
		e.src = h + "//" + u + "/p.js";
		r.appendChild(e);
	})("script", "parsely", document);
</script>

<!-- END Parse.ly Include: Standard -->
	<div style="display:none">
	<div class="grofile-hash-map-6d6080c3faf9e7d5032ef6bf6c3300d4">
	</div>
	</div>


    <!--

        Theme: Newspaper by tagDiv.com 2017
        Version: 8.7.4 (rara)
        Deploy mode: deploy
        
        uid: 5e65572e6b9a2
    -->

    <script type='text/javascript'>
/* <![CDATA[ */
var h5abPrintSettings = {"customCSS":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.tcu360.com/wp-content/plugins/print-post-and-page/js/h5ab-print.min.js?ver=5.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.tcu360.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.tcu360.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.0.2'></script>
<script type='text/javascript' src='https://www.tcu360.com/wp-content/plugins/ditty-news-ticker/legacy/static/js/jquery.touchSwipe.min.js?ver=2.2.1'></script>
<script type='text/javascript' src='https://www.tcu360.com/wp-content/plugins/ditty-news-ticker/legacy/static/js/jquery.easing.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.tcu360.com/wp-content/plugins/ditty-news-ticker/legacy/static/js/imagesloaded.pkgd.min.js?ver=4.1.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mtphr_dnt_vars = {"is_rtl":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.tcu360.com/wp-content/plugins/ditty-news-ticker/legacy/static/js/ditty-news-ticker.min.js?ver=1583697346'></script>
<script type='text/javascript' src='https://www.tcu360.com/wp-content/plugins/google-language-translator/js/scripts.js?ver=5.0.48'></script>
<script type='text/javascript' src='//translate.google.com/translate_a/element.js?cb=GoogleLanguageTranslatorInit'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sb_instagram_js_options = {"sb_instagram_at":"","font_method":"svg"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.tcu360.com/wp-content/plugins/instagram-feed/js/sb-instagram.min.js?ver=1.12'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=202010'></script>
<script type='text/javascript' src='https://www.tcu360.com/wp-content/plugins/wp-embed-facebook/lib/js/wpembedfb.min.js?ver=1.0'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2020Maraa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.0.1/modules/wpgroho.js'></script>
<script type='text/javascript' src='https://www.tcu360.com/wp-content/themes/Newspaper/js/tagdiv_theme.min.js?ver=8.7.4'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.2/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.2/wp-includes/js/wp-embed.min.js'></script>

<script>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</script>
<!-- JS generated by theme -->

<script>
    

			
				jQuery().ready(function () {
					tdWeather.addItem({"block_uid":"td_top_weather_uid","location":"Fort Worth","api_location":"Fort Worth","api_language":"en","api_key":"71834ba81b303dbc0b3801bd5545a32c","today_icon":"broken-clouds-d","today_icon_text":"overcast clouds","today_temp":[17.7,63.8],"today_humidity":63,"today_wind_speed":[4.6,2.9],"today_min":[16,60.8],"today_max":[19,66.2],"today_clouds":90,"current_unit":1,"forecast":[{"timestamp":1583701200,"day_name":"Sun","day_temp":[19,66],"owm_day_index":0},{"timestamp":1583712000,"day_name":"Mon","day_temp":[24,76],"owm_day_index":1},{"timestamp":1583798400,"day_name":"Tue","day_temp":[26,79],"owm_day_index":9},{"timestamp":1583884800,"day_name":"Wed","day_temp":[26,79],"owm_day_index":17},{"timestamp":1583971200,"day_name":"Thu","day_temp":[24,75],"owm_day_index":25},{"timestamp":1584057600,"day_name":"Fri","day_temp":[20,68],"owm_day_index":33}]});
				});
			
			

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://www.tcu360.com/wp-content/themes/Newspaper-child/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://www.tcu360.com/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>

<script type='text/javascript' src='https://stats.wp.com/e-202010.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.0.1',blog:'158778923',post:'1243792',tz:'-5',srv:'www.tcu360.com'} ]);
	_stq.push([ 'clickTrackerInit', '158778923', '1243792' ]);
</script>


			<div id="tdw-css-writer" style="display: none" class="tdw-drag-dialog tdc-window-sidebar">
				<header>

				
					<a title="Editor" class="tdw-tab tdc-tab-active" href="#" data-tab-content="tdw-tab-editor">Edit with Live CSS</a>
					<div class="tdw-less-info" title="This will be red when errors are detected in your CSS and LESS"></div>
				
				</header>
				<div class="tdw-content">

					
					<div class="tdw-tabs-content tdw-tab-editor tdc-tab-content-active">


						<script>

							(function(jQuery, undefined) {

								jQuery(window).ready(function() {

									if ( 'undefined' !== typeof tdcAdminIFrameUI ) {
										var $liveIframe  = tdcAdminIFrameUI.getLiveIframe();

										if ( $liveIframe.length ) {
											$liveIframe.load(function() {
												$liveIframe.contents().find( 'body').append( '<textarea class="tdw-css-writer-editor" style="display: none"></textarea>' );
											});
										}
									}

								});

							})(jQuery);

						</script>


						<textarea class="tdw-css-writer-editor td_live_css_uid_1_5e65572e6cdd1"></textarea>
						<div id="td_live_css_uid_1_5e65572e6cdd1" class="td-code-editor"></div>


						<script>
							jQuery(window).load(function (){

								if ( 'undefined' !== typeof tdLiveCssInject ) {

									tdLiveCssInject.init();


									var editor_textarea = jQuery('.td_live_css_uid_1_5e65572e6cdd1');
									var languageTools = ace.require("ace/ext/language_tools");
									var tdcCompleter = {
										getCompletions: function (editor, session, pos, prefix, callback) {
											if (prefix.length === 0) {
												callback(null, []);
												return
											}

											if ('undefined' !== typeof tdcAdminIFrameUI) {

												var data = {
													error: undefined,
													getShortcode: ''
												};

												tdcIFrameData.getShortcodeFromData(data);

												if (!_.isUndefined(data.error)) {
													tdcDebug.log(data.error);
												}

												if (!_.isUndefined(data.getShortcode)) {

													var regex = /el_class=\"([A-Za-z0-9_-]*\s*)+\"/g,
														results = data.getShortcode.match(regex);

													var elClasses = {};

													for (var i = 0; i < results.length; i++) {
														var currentClasses = results[i]
															.replace('el_class="', '')
															.replace('"', '')
															.split(' ');

														for (var j = 0; j < currentClasses.length; j++) {
															if (_.isUndefined(elClasses[currentClasses[j]])) {
																elClasses[currentClasses[j]] = '';
															}
														}
													}

													var arrElClasses = [];

													for (var prop in elClasses) {
														arrElClasses.push(prop);
													}

													callback(null, arrElClasses.map(function (item) {
														return {
															name: item,
															value: item,
															meta: 'in_page'
														}
													}));
												}
											}
										}
									};
									languageTools.addCompleter(tdcCompleter);

									window.editor = ace.edit("td_live_css_uid_1_5e65572e6cdd1");

									// 'change' handler is written as function because it's called by tdc_on_add_css_live_components (of wp_footer hook)
									// We did it to reattach the existing compiled css to the new content received from server.
									window.editorChangeHandler = function () {
										//tdwState.lessWasEdited = true;

										window.onbeforeunload = function () {
											if (tdwState.lessWasEdited) {
												return "You have attempted to leave this page. Are you sure?";
											}
											return false;
										};

										var editorValue = editor.getSession().getValue();

										editor_textarea.val(editorValue);

										if ('undefined' !== typeof tdcAdminIFrameUI) {
											tdcAdminIFrameUI.getLiveIframe().contents().find('.tdw-css-writer-editor:first').val(editorValue);

											// Mark the content as modified
											// This is important for showing info when composer closes
                                            tdcMain.setContentModified();
										}

										tdLiveCssInject.less();
									};

									editor.getSession().setValue(editor_textarea.val());
									editor.getSession().on('change', editorChangeHandler);

									editor.setTheme("ace/theme/textmate");
									editor.setShowPrintMargin(false);
									editor.getSession().setMode("ace/mode/less");
									editor.setOptions({
										enableBasicAutocompletion: true,
										enableSnippets: true,
										enableLiveAutocompletion: false
									});

								}

							});
						</script>

					</div>
				</div>

				<footer>

					
						<a href="#" class="tdw-save-css">Save</a>
						<div class="tdw-more-info-text">Write CSS OR LESS and hit save. CTRL + SPACE for auto-complete.</div>

					
					<div class="tdw-resize"></div>
				</footer>
			</div>
			
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"52bf905ca9","applicationID":"10317236","transactionName":"YlIDMBBWXkFXW0UNClsYIAcWXl9cGUtYCgJZUg==","queueTime":0,"applicationTime":1105,"atts":"ThUARlhMTU8=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>